top_image
Author Message

<  Endless Forest News  ~  Please test version 3.4 beta 6

ToT
Posted: Tue Jul 13, 2010 3:18 pm Reply with quote
Site Administrator Joined: 22 Apr 2008 Posts: 305 Location: Gent, Belgium
We fixed most of the bugs you found in the previous beta. So please have a look and check if they were actually fixed and if any new bugs have appeared.

You can download version 3.4 beta 6 of The Endless Forest here.

Please report all bugs you find in this thread.


Last edited by ToT on Fri Aug 06, 2010 6:45 pm; edited 1 time in total
View user's profile Send private message Visit poster's website
Soer
Posted: Tue Jul 13, 2010 10:43 pm Reply with quote
Joined: 30 Mar 2009 Posts: 42 Location: Land of Deer and Idols
When dancing, the dancing music seems to continue for 2-3 seconds after I stop dancing. It did do this in older versions too, but definitely not for this long.

While sometimes the music glitch seems fixed, this still occured to me several times I started the beta: Ambient sounds are blaringly loud while Music sounds are normal volume. I also couldn't control the volume of the Ambient and Sound Effects while I could do this with Music. When TEF was in the background, Ambient sounds had normal volume.
This does not always happen, but often enough to mention it here.
[edit:] When the sound works fine, it is significantly quieter than in previous versions.


After connecting, disconnecting and reconnecting again, fog appears (image) and everything suggests I'm connected (Green dot, Pictogram loaded, News loaded, "show all players" etc.), there are neither any deer around, nor do I see any pictograms on the black bar.


Some older glitches that still occur:
When resizing the window, Pictograms still get messed up (image) (Since v3.31)

Sometimes when entering the "Display" menu, the Screen Resolution bar automatically jumps to 960x600 resulting in having to restart the game. (Since v3.31)

The glitch where Gen2 Pictos show up differently in the game (thread) still occurs. (Since v3.31)
View user's profile Send private message
ToT
Posted: Wed Jul 14, 2010 12:07 am Reply with quote
Site Administrator Joined: 22 Apr 2008 Posts: 305 Location: Gent, Belgium
Thank you! Very helpful.
View user's profile Send private message Visit poster's website
Soer
Posted: Wed Jul 14, 2010 9:52 am Reply with quote
Joined: 30 Mar 2009 Posts: 42 Location: Land of Deer and Idols
Noticed that the Sound-glitch I mentioned only occurs when I switch to other windows while TEF is loading. I usually do other things while waiting for TEF to load + connect. When I leave the Forest-window active while it starts everything loads fine.

Another note about the Fog-thing, not sure if it helps: Others cannot see me either.

Dance music doesn't get louder when others join.


Aside from that I haven't found anything new so far, so here are some older glitches to make up for that Laughing

If you click "Log Out", you don't get properly logged out. Your Set and your Picto disappear, but to others you still have your Picto above your head. Logging in as "Guest" does the same thing. (Since ???)

Namelesses wich Michael-Pictos still pop up. (Since v3.31)

When walking out of De Drinkplaads after having transformed you get the default pelt. This is easily fixed by sneezing it off.
Also, when walking into De Drinkplaads as a critter/mini and walking out, you turn into a big deer again. This too is fixed by sneezing a transformation spell off. (And it's really handy actually Wink) (Since v3.31)
View user's profile Send private message
ToT
Posted: Wed Jul 14, 2010 9:59 am Reply with quote
Site Administrator Joined: 22 Apr 2008 Posts: 305 Location: Gent, Belgium
Thanks for the report. I hope other people can confirm these errors.

Soer wrote:
Noticed that the Sound-glitch I mentioned only occurs when I switch to other windows while TEF is loading.


I have noticed this too. It's a peculiarity of the new OGG sound system we're using: sounds are muted when the application window is not active. I'll ask the programmer if this behaviour can be changed.
View user's profile Send private message Visit poster's website
Ourania
Posted: Wed Jul 14, 2010 3:16 pm Reply with quote
Joined: 04 Feb 2010 Posts: 211
I get (as I did on the last beta) this before the game comes up:

DBA50C26-160E-4A38-A?AB-88F3454890BD.dll

I press OK and the game loads fine.
View user's profile Send private message Send e-mail
ToT
Posted: Wed Jul 14, 2010 10:12 pm Reply with quote
Site Administrator Joined: 22 Apr 2008 Posts: 305 Location: Gent, Belgium
Ourania wrote:
I get (as I did on the last beta) this before the game comes up:

DBA50C26-160E-4A38-A?AB-88F3454890BD.dll

I press OK and the game loads fine.


Have you tried a clean install?

Run the uninstaller first, then remove the remaining TEF folder.
Then install the beta.
View user's profile Send private message Visit poster's website
Verycrazygirl
Posted: Fri Jul 16, 2010 10:41 am Reply with quote
Joined: 30 Dec 2008 Posts: 89
Soer wrote:
[edit:] When the sound works fine, it is significantly quieter than in previous versions.


After connecting, disconnecting and reconnecting again, fog appears (image) and everything suggests I'm connected (Green dot, Pictogram loaded, News loaded, "show all players" etc.), there are neither any deer around, nor do I see any pictograms on the black bar.


Some older glitches that still occur:
When resizing the window, Pictograms still get messed up (image) (Since v3.31)

Sometimes when entering the "Display" menu, the Screen Resolution bar automatically jumps to 960x600 resulting in having to restart the game. (Since v3.31)

The glitch where Gen2 Pictos show up differently in the game (thread) still occurs. (Since v3.31)


Ourania wrote:
I get (as I did on the last beta) this before the game comes up:

DBA50C26-160E-4A38-A?AB-88F3454890BD.dll

I press OK and the game loads fine.


Having these problems too. Very Happy

Havent been able to fix the second quoted problem. I'm personally okay with it as long as TEF works fine haha...
View user's profile Send private message
Sluggs
Posted: Fri Jul 16, 2010 11:37 am Reply with quote
Joined: 02 Dec 2007 Posts: 1639 Location: United Kingdom
Well, after uninstalling the previous beta and installing this one, I haven't really found anything amiss with this version, apart from the dance music which takes a little time to stop, after I stop dancing.

I haven't come across any .dll problems either, in this version or the previous version. (I use Windows XP Pro SP2)
View user's profile Send private message Send e-mail Visit poster's website
Verycrazygirl
Posted: Sat Jul 17, 2010 4:56 pm Reply with quote
Joined: 30 Dec 2008 Posts: 89
Seems to be automatically saving the set that deer was last wearing when you swap accounts/ log out. Is this normal? O:

Dance music doesn't get louder as you dance with a group. ^^
View user's profile Send private message
TheIdioticOracle
Posted: Tue Jul 20, 2010 1:09 pm Reply with quote
Joined: 16 Jul 2010 Posts: 8
The "amazed/surprised" emotion is slightly different from 3.31

The legs don't fully extend anymore, and doesn't really seem to portray as much surprise.

The legs are still bent enough that it doesn't look much like the emotion button's picture.

Pic of my Fawn using the emotion:


It just doesn't look... correct.
View user's profile Send private message
ChickenWhite
Posted: Tue Jul 20, 2010 8:13 pm Reply with quote
Joined: 20 Jul 2010 Posts: 5 Location: In my own mind.
Some bugs I took note of while beta testing tEF:

Arrowkeys <-- + up = can't jump. As simple as that. if you want to jump around in a small circkle counter-clockwise, you can't.

When I start the game I get an error-message. This doens't impede the game as far as I know, but it reads as following:
Quest3D Error.
A channel that is needed for this project was not found in the installation path: E1F00F2A - EFD1 - 4AEB - A689 - 6A8465BCF5FA.

Also, a funny little glitch, when I stood up after logging in, my halo and picto made a left a copy of itself on the ground where it'd just been XD

And of course, some pictos still only appear half-finished.
View user's profile Send private message
TheIdioticOracle
Posted: Wed Jul 21, 2010 9:58 am Reply with quote
Joined: 16 Jul 2010 Posts: 8
Verycrazygirl wrote:

Dance music doesn't get louder as you dance with a group. ^^
I also noticed this problem.

Which made me sad because I love dancing in a group, and it's not as fun without the increased music..
View user's profile Send private message
TeganAndTiger
Posted: Wed Jul 21, 2010 10:40 pm Reply with quote
Joined: 22 Dec 2009 Posts: 8 Location: Scotland
ChickenWhite wrote:
Some bugs I took note of while beta testing tEF:

Arrowkeys <-- + up = can't jump. As simple as that. if you want to jump around in a small circkle counter-clockwise, you can't.

I just tried this and it works find for me.
Jumping while walking in both directions and while galloping in both directions works fine for me.
View user's profile Send private message
Seed
Posted: Wed Jul 21, 2010 11:08 pm Reply with quote
Joined: 17 Feb 2008 Posts: 502 Location: In UR Brainz, bee'n a deerz
I have had that problem in many versions. I can't even use space bar to jump on the computer I'm on! I have to use arrowkeys to walk, and if I want to jump use H, and if I want to turn and hop/jump, I have to use the letter keys for it. It bites.
View user's profile Send private message

Display posts from previous:  

All times are GMT + 2 Hours
Page 1 of 2
Goto page 1, 2  Next
This forum is locked: you cannot post, reply to, or edit topics.

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum